SnowTrace Maintenance
Incident Report for Avalanche
Resolved
This incident has been resolved.
Posted Apr 16, 2022 - 02:59 UTC
Monitoring
https://snowtrace.io is under maintenance. You can use Avascan (https://avascan.info) to view blockchain data during this downtime.

The Avalanche Network is functioning as expected and the api.avax.network is working correctly (i.e. you can still use MetaMask on the C-Chain without issue).
Posted Apr 16, 2022 - 02:30 UTC
This incident affected: Mainnet (SnowTrace).