Degraded C-Chain Explorer Performance
Incident Report for Avalanche
Resolved
This incident has been resolved.
Posted Oct 29, 2021 - 05:33 UTC
Investigating
We are currently investigating degraded C-Chain Explorer performance.
Posted Oct 29, 2021 - 05:16 UTC
This incident affected: Mainnet (Explorer).