Scheduled Maintenance
Incident Report for Avalanche
Resolved
This incident has been resolved.
Posted Feb 07, 2022 - 14:28 UTC
Investigating
Posted Feb 07, 2022 - 08:14 UTC
This incident affected: Mainnet (SnowTrace) and Fuji (SnowTrace).