A fix has been implemented and we are monitoring the results.
Posted Jul 28, 2026 - 16:34 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jul 28, 2026 - 16:08 UTC
Update
We are continuing to investigate this issue.
Posted Jul 28, 2026 - 15:52 UTC
Update
We are continuing to investigate this issue.
Posted Jul 28, 2026 - 15:51 UTC
Update
We are continuing to investigate this issue impacting Fuji(Testnet) C-Chain block ingestion.
Posted Jul 28, 2026 - 15:46 UTC
Update
We are continuing to investigate this issue impacting Fuji(Testnet) C-Chain block ingestion.
Posted Jul 28, 2026 - 15:31 UTC
Update
We are continuing to investigate this issue impacting Fuji(Testnet) C-Chain block ingestion.
Posted Jul 28, 2026 - 15:10 UTC
Investigating
We are currently investigating delayed C-Chain block indexing on Fuji (Testnet) after the Helicon activation. This impacts Fuji (Testnet) ONLY, Mainnet indexing is fully operational.
Posted Jul 28, 2026 - 15:09 UTC
This incident affected: Supporting Services (Explorer).