BTC Bridge Maintenance

Incident Report for Avalanche

Resolved

Maintenance is complete.
Posted Jul 12, 2022 - 04:06 UTC

Investigating

The BTC Bridge is undergoing some maintenance. During this time, transactions between Avalanche and Bitcoin may be delayed.

This maintenance does not affect the EVM Bridge or the Avalanche Network.
Posted Jul 12, 2022 - 01:51 UTC
This incident affected: Bridge (Mainnet).