C-Chain explorer delay

Incident Report for Avalanche

Resolved

Data has been backfilled, the explorer is now up fully up to date.
Posted Oct 20, 2025 - 14:52 UTC

Monitoring

Service has been restored and data is being backfilled. We are continuing to monitor the recovery.
Posted Oct 20, 2025 - 13:18 UTC

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 13:17 UTC

Identified

Our data processing infrastructure is running behind which is causing delayed ingestion of C-Chain Explorer. Team is working on restoring the service.
Posted Oct 20, 2025 - 12:15 UTC
This incident affected: Supporting Services (Explorer).