SnowTrace Outage
Incident Report for Avalanche
Resolved
This incident has been resolved.
Posted Apr 13, 2023 - 00:41 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2023 - 00:13 UTC
Investigating
SnowTrace is currently inaccessible. The Etherscan team is currently investigating the issue.

This outage does not affect the Avalanche Network. To view ongoing C-Chain activity, you can visit:
* https://subnets.avax.network/c-chain
* https://avascan.info/blockchain/c/home
Posted Apr 12, 2023 - 23:30 UTC
This incident affected: SnowTrace (Mainnet).