SnowTrace Block Ingestion Stuck
Incident Report for Avalanche
Resolved
This incident has been resolved.
Posted Dec 20, 2021 - 00:51 UTC
Identified
The issue has been resolved and SnowTrace is now catching up to tip.
Posted Dec 20, 2021 - 00:27 UTC
Investigating
SnowTrace block ingestion is currently stuck. The Etherscan team is working on a fix.

The Avalanche Network is working as expected. You can view C-Chain activity on Avascan until service is restored on SnowTrace: https://avascan.info/
Posted Dec 19, 2021 - 22:42 UTC
This incident affected: Explorer (Mainnet).