SnowTrace Maintenance
Incident Report for Avalanche
Resolved
This incident has been resolved.
Posted Jan 29, 2022 - 05:13 UTC
Investigating
We are currently performing DNS maintenance on SnowTrace.io. It will be back up shortly.

You can also access C-Chain data on https://avascan.info/ and https://stats.avax.network/dashboard/c-chain-activity.
Posted Jan 28, 2022 - 21:11 UTC
This incident affected: SnowTrace (Mainnet) and SnowTrace (Fuji).