Wallet Backend Upgrade
Incident Report for Avalanche
Resolved
This incident has been resolved.
Posted Feb 17, 2022 - 20:50 UTC
Investigating
We are running an upgrade on the wallet backend. It will be back up shortly.

The Avalanche Network is working as expected. This only affects the Wallet.
Posted Feb 17, 2022 - 20:38 UTC
This incident affected: Wallet and Wallet (Beta).