Validator Health Check Under Maintenance
Incident Report for Avalanche
Resolved
This incident has been resolved.
Posted Oct 28, 2022 - 17:26 UTC
Identified
The Validator Health Check is currently under maintenance. In the meantime, you can use https://check.allnodes.com/avax/[NodeID] or https://avascan.info/staking/validator/[NodeID] to check the health of your validator.

This issue does not affect the Avalanche Network.
Posted Oct 18, 2022 - 19:21 UTC
This incident affected: Stats and Notify.