P-Chain Transaction Processing Delays
Incident Report for Avalanche
Resolved
P-Chain transactions are being accepted as expected.

Primary Network Validator nodes are encouraged to upgrade to the latest AvalancheGo release (linked below) to leverage the latest P-Chain mempool handling improvements.

https://github.com/ava-labs/avalanchego/releases/tag/v1.12.1
Posted Dec 17, 2024 - 23:27 UTC
Monitoring
For the past few hours, transactions issued on the Avalanche P-Chain experienced delays due to improper P-Chain transaction mempool handling.

A fix has been identified and improved acceptance times are being observed. Valid transactions issued during this time should now be included in blocks. If any transactions were dropped from the mempool, they can be safely re-issued.

The Avalanche X- and C-Chains, and Avalanche L1s are not impacted.
Posted Dec 17, 2024 - 14:47 UTC
This incident affected: Network (Mainnet).