Numerous Websites Inaccessible

Incident Report for Avalanche

Resolved

This incident has been resolved.
Posted Oct 30, 2023 - 20:36 UTC

Monitoring

Cloudflare implemented a fix that is restoring service to the impacted sites. We are monitoring stability.
Posted Oct 30, 2023 - 20:22 UTC

Investigating

Due to an ongoing Cloudflare incident (https://www.cloudflarestatus.com/incidents/l6x2h1zp69bc), some websites are inaccessible. We are working with Cloudflare to restore service as soon as possible.

This outage does not affect the Avalanche Network. You can view current transaction activity here: https://snowtrace.io/
Posted Oct 30, 2023 - 20:12 UTC
This incident affected: Core (Core Extension) and Supporting Services (Explorer, Faucet, Stats).