Delayed Block Ingestion on P-Chain Explorer
Incident Report for Avalanche
Resolved
This incident has been resolved.
Posted Mar 22, 2023 - 15:39 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 21, 2023 - 21:12 UTC
Investigating
Block ingestion is currently delayed on the P-Chain Block Explorer (https://subnets.avax.network/p-chain). In the meantime, please use AvaScan's P-Chain Block Explorer (https://avascan.info/blockchain/p/home).

We are currently investigating the issue. The Avalanche Network is operating as expected.
Posted Mar 20, 2023 - 22:42 UTC
This incident affected: Explorer (Mainnet).