C-Chain Explorer Maintenance
Incident Report for Avalanche
Resolved
This incident has been resolved.
Posted Oct 26, 2021 - 22:30 UTC
Monitoring
We are performing temporary maintenance on the C-Chain Explorer. During this time, the explorer will be inaccessible.
Posted Oct 26, 2021 - 21:02 UTC
This incident affected: Mainnet (Explorer).