SnowTrace Block Ingestion Delayed
Incident Report for Avalanche
Resolved
This incident has been resolved.
Posted Nov 22, 2023 - 03:24 UTC
Monitoring
A fix has been implemented and Etherscan is monitoring the results.
Posted Nov 22, 2023 - 03:09 UTC
Investigating
Block processing is delayed on https://snowtrace.io/. The Etherscan team is currently investigating.

This outage does not affect the Avalanche Network. You can view recent transaction activity on https://43114.snowtrace.dev/ or https://subnets.avax.network/c-chain.
Posted Nov 22, 2023 - 02:10 UTC
This incident affected: SnowTrace (Mainnet).