Stats Page Inaccessible
Incident Report for Avalanche
Resolved
This incident has been resolved.
Posted Oct 11, 2022 - 18:14 UTC
Identified
We have identified the issue and are working with our partners to bring https://stats.avax.network back online.

This issue does not affect the Avalanche Network. In the meantime, checkout the stats on https://subnets.avax.network/stats.
Posted Oct 11, 2022 - 17:43 UTC
This incident affected: Stats.