BTC Balances/Transactions Unavailable

Incident Report for Avalanche

Resolved

This incident has been resolved.
Posted Aug 01, 2022 - 01:09 UTC

Investigating

BTC Balances and Transactions in Core are unavailable because of an issue with an upstream provider. We are currently working on fixing the issue and apologize for the inconvenience.
Posted Aug 01, 2022 - 00:51 UTC
This incident affected: Core (Core Browser Extension).