Validator Version Info Unavailable
Incident Report for Avalanche Platform
Resolved
This issue has been resolved.
Posted May 21, 2021 - 00:00 UTC
Investigating
Validator version info is currently unavailable on explorer.avax.network. We are investigating the issue.
Posted May 20, 2021 - 23:43 UTC
This incident affected: Mainnet (Explorer).